summaryrefslogtreecommitdiffstats
path: root/libgloss/visium/configure.in
diff options
context:
space:
mode:
authorEric Botcazou <ebotcazou@adacore.com>2015-01-21 18:27:47 +0000
committerEric Botcazou <ebotcazou@adacore.com>2015-01-21 18:27:47 +0000
commitbf8f43ae8adf162d9acedd9dd4d4f9d3d4f0a646 (patch)
treea5510f14588e74673eab7f8dbd53be8acf1a055f /libgloss/visium/configure.in
parentf485f162769910e0733ff92830706e3c5f4c1a1d (diff)
downloadcygnal-bf8f43ae8adf162d9acedd9dd4d4f9d3d4f0a646.tar.gz
cygnal-bf8f43ae8adf162d9acedd9dd4d4f9d3d4f0a646.tar.bz2
cygnal-bf8f43ae8adf162d9acedd9dd4d4f9d3d4f0a646.zip
* COPYING.LIBGLOSS: Add Controls and Data Services copyright.
* COPYING.NEWLIB: Likewise. libgloss/ * configure.in: Add Visium support. * configure: Regenerate. * visium/: New directory. newlib/ * configure.host: Add Visium support. * libc/machine/configure.in: Likewise. * libc/machine/configure: Regenerate. * libc/machine/visium/: New directory. * libc/include/machine/setjmp.h (_JBLEN): Define for Visium. * libc/include/machine/ieeefp.h (__IEEE_BIG_ENDIAN): Likewise. * libc/include/machine/time.h (_CLOCKS_PER_SEC_): Likewise.
Diffstat (limited to 'libgloss/visium/configure.in')
-rw-r--r--libgloss/visium/configure.in58
1 files changed, 58 insertions, 0 deletions
diff --git a/libgloss/visium/configure.in b/libgloss/visium/configure.in
new file mode 100644
index 000000000..33c1872c7
--- /dev/null
+++ b/libgloss/visium/configure.in
@@ -0,0 +1,58 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+AC_INIT(syscalls.c)
+
+if test "${enable_shared}" = "yes" ; then
+ echo "Shared libraries not supported for cross compiling, ignored"
+fi
+
+if test "$srcdir" = "." ; then
+ if test "${with_target_subdir}" != "." ; then
+ libgloss_topdir="${srcdir}/${with_multisrctop}../../.."
+ else
+ libgloss_topdir="${srcdir}/${with_multisrctop}../.."
+ fi
+else
+ libgloss_topdir="${srcdir}/../.."
+fi
+AC_CONFIG_AUX_DIR($libgloss_topdir)
+
+AC_CANONICAL_SYSTEM
+AC_ARG_PROGRAM
+
+AC_PROG_INSTALL
+
+LIB_AC_PROG_CC
+AS=${AS-as}
+AC_SUBST(AS)
+AR=${AR-ar}
+AC_SUBST(AR)
+LD=${LD-ld}
+AC_SUBST(LD)
+AC_PROG_RANLIB
+LIB_AM_PROG_AS
+
+host_makefile_frag=${srcdir}/../config/default.mh
+
+dnl We have to assign the same value to other variables because autoconf
+dnl doesn't provide a mechanism to substitute a replacement keyword with
+dnl arbitrary data or pathnames.
+dnl
+host_makefile_frag_path=$host_makefile_frag
+AC_SUBST(host_makefile_frag_path)
+AC_SUBST_FILE(host_makefile_frag)
+target_makefile_frag_path=$target_makefile_frag
+AC_SUBST(target_makefile_frag_path)
+AC_SUBST_FILE(target_makefile_frag)
+AC_SUBST(part_specific_obj)
+
+AC_CONFIG_FILES(Makefile,
+. ${libgloss_topdir}/config-ml.in,
+srcdir=${srcdir}
+target=${target}
+with_multisubdir=${with_multisubdir}
+ac_configure_args="${ac_configure_args} --enable-multilib"
+CONFIG_SHELL=${CONFIG_SHELL-/bin/sh}
+libgloss_topdir=${libgloss_topdir}
+)
+AC_OUTPUT