summaryrefslogtreecommitdiffstats
path: root/newlib/libc/sys/linux/machine/configure.in
diff options
context:
space:
mode:
authorJeff Johnston <jjohnstn@redhat.com>2002-04-03 22:46:21 +0000
committerJeff Johnston <jjohnstn@redhat.com>2002-04-03 22:46:21 +0000
commitfa4a16a17afb05a7c6acfab467c1c03788a3fed3 (patch)
treec511596e7eaba195216fb76732135fe78a7bd1f7 /newlib/libc/sys/linux/machine/configure.in
parente432b38efed39310dbdd2763db075ab439f59654 (diff)
downloadcygnal-fa4a16a17afb05a7c6acfab467c1c03788a3fed3.tar.gz
cygnal-fa4a16a17afb05a7c6acfab467c1c03788a3fed3.tar.bz2
cygnal-fa4a16a17afb05a7c6acfab467c1c03788a3fed3.zip
2002-04-03 Jeff Johnston <jjohnstn@redhat.com>
* configure.host: Add support for machine subdirectory of sys subdirectory. * configure.in: Add check for sys machine subdirectory. * Makefile.am: Ditto. * configure: Regenerated. * Makefile.in: Ditto. * libc/sys/linux/crt0.c: Moved to machine/i386 directory. * libc/sys/linux/sys/syscall.h: Ditto. * libc/sys/linux/sleep.c: New file. * libc/sys/linux/socket.c: Ditto. * libc/sys/linux/sockops.h: Ditto. * libc/sys/linux/stack.c: Ditto. * libc/sys/linux/usleep.c: Ditto. * libc/sys/linux/machine/Makefile.am: Ditto. * libc/sys/linux/machine/Makefile.in: Ditto. * libc/sys/linux/machine/aclocal.m4: Ditto. * libc/sys/linux/machine/configure: Ditto. * libc/sys/linux/machine/configure.in: Ditto. * libc/sys/linux/machine/i386/Makefile.am: Ditto. * libc/sys/linux/machine/i386/Makefile.in: Ditto. * libc/sys/linux/machine/i386/aclocal.m4: Ditto. * libc/sys/linux/machine/i386/configure: Ditto. * libc/sys/linux/machine/i386/configure.in: Ditto. * libc/sys/linux/machine/i386/crt0.c: Ditto. * libc/sys/linux/machine/i386/sigset.c: Ditto. * libc/sys/linux/machine/i386/sigstack.h: Ditto. * libc/sys/linux/machine/i386/socketcall.h: Ditto. * libc/sys/linux/machine/i386/syscall.h: Ditto. * libc/sys/linux/sys/select.h: Ditto. * libc/sys/linux/configure.in: Add support for machine directory. * libc/sys/linux/Makefile.am: Ditto plus add new files above. * libc/sys/linux/Makefile.in: Regenerated. * libc/sys/linux/configure: Ditto. * libc/sys/linux/brk.c: Use machine/syscall.h instead of sys/syscall.h. * libc/sys/linux/inode.c: Ditto. * libc/sys/linux/linux.c: Ditto. * libc/sys/linux/process.c: Ditto. * libc/sys/linux/systat.c: Ditto. * libc/sys/linux/time.c: Ditto. * libc/sys/linux/wait.c: Ditto. * libc/sys/linux/ids.c: Change header plus add setfsgid/setfsuid. * libc/sys/linux/io.c: Change header plus add readv/writev. * libc/sys/linux/signal.c: Change header plus change sigsuspend to use __sigsuspend syscall. * libc/sys/linux/select.c: Change header plus change select to use _newselect syscall. * libc/sys/linux/sys/cdefs.h: Add a number of standard definitions used by glibc header files. * libc/sys/linux/sys/types.h: Add __socklen_t and __useconds_t types.
Diffstat (limited to 'newlib/libc/sys/linux/machine/configure.in')
-rw-r--r--newlib/libc/sys/linux/machine/configure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/newlib/libc/sys/linux/machine/configure.in b/newlib/libc/sys/linux/machine/configure.in
new file mode 100644
index 000000000..a9dc30c9d
--- /dev/null
+++ b/newlib/libc/sys/linux/machine/configure.in
@@ -0,0 +1,32 @@
+dnl This is the newlib/libc/sys configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(i386)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../../../../..)
+
+NEWLIB_CONFIGURE(../../../..)
+
+dnl We have to enable libtool after NEWLIB_CONFIGURE because if we try and
+dnl add it into NEWLIB_CONFIGURE, executable tests are made before the first
+dnl line of the macro which fail because appropriate LDFLAGS are not set.
+if test "${use_libtool}" = "yes"; then
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+fi
+
+if test -n "${machine_dir}"; then
+ AC_CONFIG_SUBDIRS(${machine_dir})
+fi
+
+CRT0=
+if test -n "${machine_dir}"; then
+ CRT0=crt0.o
+fi
+AC_SUBST(CRT0)
+
+AM_CONDITIONAL(HAVE_MACHINE_DIR, test x${machine_dir} != x)
+
+AC_OUTPUT(Makefile)