summaryrefslogtreecommitdiffstats
path: root/newlib/libm/machine/configure.in
diff options
context:
space:
mode:
authorThomas Fitzsimmons <fitzsim@redhat.com>2001-12-13 23:50:11 +0000
committerThomas Fitzsimmons <fitzsim@redhat.com>2001-12-13 23:50:11 +0000
commit2e1a71756e754ada402efe9f5e2d6378dc11e496 (patch)
tree7df86f70bc78f4f8b0bcef05c1a4d677d8fc400f /newlib/libm/machine/configure.in
parentb92591a1fc53f2d5c42faaf438f697006bf63a82 (diff)
downloadcygnal-2e1a71756e754ada402efe9f5e2d6378dc11e496.tar.gz
cygnal-2e1a71756e754ada402efe9f5e2d6378dc11e496.tar.bz2
cygnal-2e1a71756e754ada402efe9f5e2d6378dc11e496.zip
* Makefile.shared: New file.
* libc/sys/linux/shared.ld: New file. * libm/machine/*: New files. * libm/machine/i386/*: New files. * Makefile.am: Add libtool support. Change math and mathfp references to variables. * configure.host: Add variables for libtool support. Add libm_machine_dir variable. * configure.in: Add objectlist variables, for libtool support. Add CC_FOR_BUILD tests. * libc/Makefile.am: Add libtool support. Change crt0.o reference to be a variable reference. * libc/configure.in: Add libtool support. Change sublib names to be lib${subdir}.la when using libtool. * libc/ctype/Makefile.am: Add libtool support. * libc/errno/Makefile.am: Likewise. * libc/locale/Makefile.am: Likewise. * libc/machine/Makefile.am: Likewise. * libc/machine/configure.in: Likewise. * libc/machine/i386/Makefile.am: Likewise. * libc/machine/i386/configure.in: Likewise. * libc/misc/Makefile.am: Likewise. * libc/posix/Makefile.am: Likewise. * libc/reent/Makefile.am: Likewise. * libc/signal/Makefile.am: Likewise. * libc/stdio/Makefile.am: Likewise. * libc/stdlib/Makefile.am: Likewise. * libc/string/Makefile.am: Likewise. * libc/sys/Makefile.am: Likewise. * libc/sys/configure.in: Likewise. * libc/sys/linux/Makefile.am: Add libtool support. Change awk reference to a variable reference. Change signal.h reference to a variable reference. * libc/sys/linux/configure.in: Add libtool support. * libc/syscalls/Makefile.am: Likewise. * libc/time/Makefile.am: Likewise. * libc/unix/Makefile.am: Likewise. * libm/Makefile.am: Add libtool support. Change math and mathfp references to variables. * libm/configure.in: Add libtool support. Add LIBM_MACHINE_LIB variable. * libm/common/Makefile.am: Add libtool support. * libm/math/Makefile.am: Likewise. * libm/mathfp/Makefile.am: Likewise. Regenerate all Makefile.in, aclocal.m4, and configure.
Diffstat (limited to 'newlib/libm/machine/configure.in')
-rw-r--r--newlib/libm/machine/configure.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/newlib/libm/machine/configure.in b/newlib/libm/machine/configure.in
new file mode 100644
index 000000000..00a27a1e6
--- /dev/null
+++ b/newlib/libm/machine/configure.in
@@ -0,0 +1,39 @@
+dnl This is the newlib/libm/machine configure.in file.
+dnl Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.5)
+AC_INIT(i386)
+
+dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
+AC_CONFIG_AUX_DIR(../../..)
+
+NEWLIB_CONFIGURE(../..)
+
+dnl We have to add the following lines because automake detects the
+dnl references to libtool libraries from aclocal and tries to verify that
+dnl AM_PROG_LIBTOOL is being used. This must be added after
+dnl the call to NEWLIB_CONFIGURE.
+
+if test "${use_libtool}" = "yes"; then
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+fi
+
+machlib=
+
+if test -n "${libm_machine_dir}"; then
+ AC_CONFIG_SUBDIRS(${libm_machine_dir})
+ if test "${use_libtool}" = "yes"; then
+ machlib=${libm_machine_dir}/lib${libm_machine_dir}.${aext}
+ else
+ machlib=${libm_machine_dir}/lib.${aext}
+ fi
+fi
+
+AC_SUBST(libm_machine_dir)
+AC_SUBST(machlib)
+
+AC_OUTPUT(Makefile)
+
+
+