summaryrefslogtreecommitdiffstats
path: root/newlib/libc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/Makefile.am')
-rw-r--r--newlib/libc/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/newlib/libc/Makefile.am b/newlib/libc/Makefile.am
index 7a22c0269..7e8bdba1d 100644
--- a/newlib/libc/Makefile.am
+++ b/newlib/libc/Makefile.am
@@ -114,7 +114,7 @@ SUBDEFS = \
$(LIBC_EXTRA_DEF) \
misc/stmp-def
-libc.info: sigset.texi targetdep.tex $(SUBDEFS)
+libc.info: sigset.texi extra.texi targetdep.tex $(SUBDEFS)
stmp-sigset: config.status
if test -n "$(LIBC_SIGNAL_LIB)"; then \
@@ -127,6 +127,17 @@ stmp-sigset: config.status
sigset.texi: stmp-sigset ; @true
+stmp-extra: config.status
+ if test -n "$(LIBC_EXTRA_LIB)"; then \
+ echo "@set EXTRA" >tmp.texi; \
+ else \
+ echo "@clear EXTRA" >tmp.texi; \
+ fi
+ $(SHELL) $(newlib_basedir)/../move-if-change tmp.texi extra.texi
+ touch $@
+
+extra.texi: stmp-extra ; @true
+
stmp-targetdep: force
rm -f tmp.texi
targetdoc=`pwd`/tmp.texi; \