summaryrefslogtreecommitdiffstats
path: root/newlib/libc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/configure.in')
-rw-r--r--newlib/libc/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/newlib/libc/configure.in b/newlib/libc/configure.in
index 8a6b81d85..0a7bb8815 100644
--- a/newlib/libc/configure.in
+++ b/newlib/libc/configure.in
@@ -26,6 +26,16 @@ AC_ARG_ENABLE(newlib_nano_malloc,
*) AC_MSG_ERROR(bad value ${enableval} for newlib-nano-malloc) ;;
esac],[newlib_nano_malloc=])
+dnl Support --enable-newlib-nano-formatted-io used by libc/stdio
+AC_ARG_ENABLE(newlib_nano_formatted_io,
+[ --enable-newlib-nano-formatted-io Use small-footprint nano-formatted-IO implementation],
+[case "${enableval}" in
+ yes) newlib_nano_formatted_io=yes ;;
+ no) newlib_nano_formatted_io=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for newlib-nano-formatted-io) ;;
+ esac],[newlib_nano_formatted_io=no])
+AM_CONDITIONAL(NEWLIB_NANO_FORMATTED_IO, test x$newlib_nano_formatted_io = xyes)
+
NEWLIB_CONFIGURE(..)
AM_CONDITIONAL(NEWLIB_NANO_MALLOC, test x$newlib_nano_malloc = xyes)