summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/i386/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/i386/configure.in')
-rw-r--r--newlib/libc/machine/i386/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/newlib/libc/machine/i386/configure.in b/newlib/libc/machine/i386/configure.in
index 63c080480..b04f8b695 100644
--- a/newlib/libc/machine/i386/configure.in
+++ b/newlib/libc/machine/i386/configure.in
@@ -9,6 +9,16 @@ AC_CONFIG_AUX_DIR(../../../..)
NEWLIB_CONFIGURE(../../..)
+dnl We have to add the following lines because automake detects the
+dnl references to libtool libraries from aclocal and tries to verify that
+dnl AM_PROG_LIBTOOL is being used. This code must occur after
+dnl NEWLIB_CONFIGURE.
+
+if test "${use_libtool}" = "yes"; then
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+fi
+
AM_CONDITIONAL(MACH_ADD_SETJMP, test "x$mach_add_setjmp" = 'xtrue')
AC_OUTPUT(Makefile)