summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/sh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/sh/Makefile.am')
-rw-r--r--newlib/libc/machine/sh/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/newlib/libc/machine/sh/Makefile.am b/newlib/libc/machine/sh/Makefile.am
index 1aab718dd..9cb529347 100644
--- a/newlib/libc/machine/sh/Makefile.am
+++ b/newlib/libc/machine/sh/Makefile.am
@@ -6,7 +6,11 @@ INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
noinst_LIBRARIES = lib.a
+if SH64
+lib_a_SOURCES = setjmp.S
+else
lib_a_SOURCES = memcpy.S memset.S setjmp.S strcpy.S strcmp.S
+endif
memcpy.o: asm.h
memset.o: asm.h