summaryrefslogtreecommitdiffstats
path: root/newlib/libc/machine/sh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/machine/sh/Makefile.am')
-rw-r--r--newlib/libc/machine/sh/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/newlib/libc/machine/sh/Makefile.am b/newlib/libc/machine/sh/Makefile.am
index dd4048bc1..14cd95a00 100644
--- a/newlib/libc/machine/sh/Makefile.am
+++ b/newlib/libc/machine/sh/Makefile.am
@@ -6,13 +6,18 @@ INCLUDES = $(NEWLIB_CFLAGS) $(CROSS_CFLAGS) $(TARGET_CFLAGS)
noinst_LIBRARIES = lib.a
+if SH64
+lib_a_SOURCES = memcpy.S memset.S setjmp.S strcpy.S strlen.S strcmp.S strncpy.S
+else
lib_a_SOURCES = memcpy.S memset.S setjmp.S strcpy.S strlen.S strcmp.S
+endif
memcpy.o: asm.h
memset.o: asm.h
setjmp.o: asm.h
strcpy.o: asm.h
strcmp.o: asm.h
+strncpy.o: asm.h
ACLOCAL_AMFLAGS = -I ../../..
CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host