summaryrefslogtreecommitdiffstats
path: root/newlib/libc/stdio/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/stdio/Makefile.am')
-rw-r--r--newlib/libc/stdio/Makefile.am34
1 files changed, 29 insertions, 5 deletions
diff --git a/newlib/libc/stdio/Makefile.am b/newlib/libc/stdio/Makefile.am
index c8d689e25..f09ed22e8 100644
--- a/newlib/libc/stdio/Makefile.am
+++ b/newlib/libc/stdio/Makefile.am
@@ -25,6 +25,7 @@ GENERAL_SOURCES = \
fread.c \
freopen.c \
fscanf.c \
+ fiscanf.c \
fseek.c \
fsetpos.c \
ftell.c \
@@ -39,6 +40,7 @@ GENERAL_SOURCES = \
getline.c \
gets.c \
iprintf.c \
+ iscanf.c \
makebuf.c \
perror.c \
printf.c \
@@ -53,11 +55,13 @@ GENERAL_SOURCES = \
rewind.c \
rget.c \
scanf.c \
+ sccl.c \
setbuf.c \
setbuffer.c \
setlinebuf.c \
setvbuf.c \
siprintf.c \
+ siscanf.c \
sniprintf.c \
snprintf.c \
sprintf.c \
@@ -66,10 +70,14 @@ GENERAL_SOURCES = \
tmpfile.c \
tmpnam.c \
ungetc.c \
- vfscanf.c \
+ viprintf.c \
+ viscanf.c \
vprintf.c \
vscanf.c \
+ vsiprintf.c \
+ vsiscanf.c \
vsnprintf.c \
+ vsniprintf.c \
vsprintf.c \
vsscanf.c \
wbuf.c \
@@ -80,6 +88,7 @@ if ELIX_LEVEL_1
LIB_OBJS =
else
LIB_OBJS = \
+ asiprintf.$(oext) \
asprintf.$(oext) \
fcloseall.$(oext) \
fseeko.$(oext) \
@@ -87,10 +96,11 @@ LIB_OBJS = \
getw.$(oext) \
mktemp.$(oext) \
putw.$(oext) \
+ vasiprintf.$(oext) \
vasprintf.$(oext)
endif
-LIBADD_OBJS = vfiprintf.$(oext) vfprintf.$(oext)
+LIBADD_OBJS = vfiprintf.$(oext) vfprintf.$(oext) vfiscanf.$(oext)
libstdio_la_LDFLAGS = -Xcompiler -nostdlib
@@ -121,6 +131,12 @@ vfprintf.$(oext): vfprintf.c
vfiprintf.$(oext): vfprintf.c
$(LIB_COMPILE) -fshort-enums -DINTEGER_ONLY -c $(srcdir)/vfprintf.c -o $@
+vfscanf.$(oext): vfscanf.c
+ $(LIB_COMPILE) -c $(srcdir)/vfscanf.c
+
+vfiscanf.$(oext): vfscanf.c
+ $(LIB_COMPILE) -DINTEGER_ONLY -c $(srcdir)/vfscanf.c -o $@
+
CHEWOUT_FILES = \
clearerr.def \
fclose.def \
@@ -151,7 +167,6 @@ CHEWOUT_FILES = \
getline.def \
gets.def \
getw.def \
- iprintf.def \
mktemp.def \
perror.def \
putc.def \
@@ -168,13 +183,15 @@ CHEWOUT_FILES = \
setlinebuf.def \
setvbuf.def \
siprintf.def \
- sniprintf.def \
+ siscanf.def \
sprintf.def \
sscanf.def \
tmpfile.def \
tmpnam.def \
vfprintf.def \
- vfscanf.def
+ vfscanf.def \
+ viprintf.def \
+ viscanf.def
SUFFIXES = .def
@@ -204,6 +221,7 @@ ftell.$(oext): local.h
fvwrite.$(oext): local.h fvwrite.h
fwalk.$(oext): local.h
fwrite.$(oext): local.h fvwrite.h
+iscanf.$(oext): local.h
makebuf.$(oext): local.h
puts.$(oext): fvwrite.h
refill.$(oext): local.h
@@ -211,14 +229,20 @@ scanf.$(oext): local.h
setbuf.$(oext): local.h
setvbuf.$(oext): local.h
siprintf.$(oext): local.h
+sniprintf.$(oext): local.h
sprintf.$(oext): local.h
+siscanf.$(oext): local.h
sscanf.$(oext): local.h
stdio.$(oext): local.h
ungetc.$(oext): local.h
vfiprintf.$(oext): local.h
vfprintf.$(oext): local.h
+vfiscanf.$(oext): local.h floatio.h
vfscanf.$(oext): local.h floatio.h
+viscanf.$(oext): local.h
vscanf.$(oext): local.h
+vsniprintf.$(oext): local.h
+vsiscanf.$(oext): local.h
vsscanf.$(oext): local.h
wbuf.$(oext): local.h fvwrite.h
wsetup.$(oext): local.h