summaryrefslogtreecommitdiffstats
path: root/newlib/libm/machine/nds32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libm/machine/nds32/Makefile.am')
-rw-r--r--newlib/libm/machine/nds32/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/newlib/libm/machine/nds32/Makefile.am b/newlib/libm/machine/nds32/Makefile.am
new file mode 100644
index 000000000..b5afbd399
--- /dev/null
+++ b/newlib/libm/machine/nds32/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to generate Makefile.in
+
+AUTOMAKE_OPTIONS = cygnus
+
+INCLUDES = -I $(newlib_basedir)/../newlib/libm/common $(NEWLIB_CFLAGS) \
+ $(CROSS_CFLAGS) $(TARGET_CFLAGS)
+
+if HAS_NDS32_FPU_SP_FALSE
+GPR_SOURCES =
+else
+FPU_SP_SOURCES = wf_sqrt.S
+endif
+
+if HAS_NDS32_FPU_DP_FALSE
+else
+FPU_DP_SOURCES = w_sqrt.S
+endif
+
+LIB_SOURCES = $(GPR_SOURCES) $(FPU_SP_SOURCES) $(FPU_DP_SOURCES)
+
+noinst_LIBRARIES = lib.a
+lib_a_SOURCES = $(LIB_SOURCES)
+lib_a_CFLAGS = $(AM_CFLAGS)
+lib_a_CCASFLAGS = $(AM_CCASFLAGS)
+noinst_DATA =
+
+include $(srcdir)/../../../Makefile.shared
+
+ACLOCAL_AMFLAGS = -I ../../.. -I ../../../..
+CONFIG_STATUS_DEPENDENCIES = $(newlib_basedir)/configure.host