summaryrefslogtreecommitdiffstats
path: root/winsup/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'winsup/configure.in')
-rwxr-xr-xwinsup/configure.in24
1 files changed, 4 insertions, 20 deletions
diff --git a/winsup/configure.in b/winsup/configure.in
index c40d3d2c4..a1625d514 100755
--- a/winsup/configure.in
+++ b/winsup/configure.in
@@ -32,33 +32,17 @@ case "$target" in
if ! test -d $srcdir/cygwin; then
AC_MSG_ERROR("No cygwin dir. Can't build Cygwin. Exiting...")
fi
- AC_CONFIG_SUBDIRS(cygwin)
+ AC_CONFIG_SUBDIRS(cygwin cygserver lsaauth utils doc)
INSTALL_LICENSE="install-license"
;;
*mingw*)
if ! test -d $srcdir/mingw; then
AC_MSG_ERROR("No mingw dir. Can't build Mingw. Exiting...")
fi
- ;;
-esac
-
-if test -d $srcdir/mingw; then
- AC_CONFIG_SUBDIRS(mingw)
-fi
-AC_CONFIG_SUBDIRS(w32api cygserver)
-
-case "$with_cross_host" in
- ""|*cygwin*)
- # if test -d $srcdir/bz2lib; then
- # AC_CONFIG_SUBDIRS(bz2lib)
- # fi
- # if test -d $srcdir/zlib; then
- # AC_CONFIG_SUBDIRS(zlib)
- # fi
- if test -d $srcdir/lsaauth; then
- AC_CONFIG_SUBDIRS(lsaauth)
+ AC_CONFIG_SUBDIRS(mingw)
+ if test -d $srcdir/w32api; then
+ AC_CONFIG_SUBDIRS(w32api)
fi
- AC_CONFIG_SUBDIRS(utils doc)
;;
esac