summaryrefslogtreecommitdiffstats
path: root/winsup/cygserver/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'winsup/cygserver/configure.in')
-rw-r--r--winsup/cygserver/configure.in18
1 files changed, 0 insertions, 18 deletions
diff --git a/winsup/cygserver/configure.in b/winsup/cygserver/configure.in
index f0fd4b01a..30b023232 100644
--- a/winsup/cygserver/configure.in
+++ b/winsup/cygserver/configure.in
@@ -44,26 +44,8 @@ AC_CHECK_TOOL(NM, nm, nm)
AC_CHECK_TOOL(DLLTOOL, dlltool, dlltool)
AC_CHECK_TOOL(WINDRES, windres, windres)
-AC_ALLOCA
AC_PROG_MAKE_SET
-dnl check whether gcc supports __builtin_memset.
-# Test for builtin mem* functions.
-AC_LANG_SAVE
-AC_LANG_CPLUSPLUS
-AC_TRY_COMPILE([
-#include <string.h>
-void foo(char *s, int c, size_t n)
-{
- __builtin_memset(s, c, n);
-}
-], [ ],
-use_builtin_memset=yes, use_builtin_memset=no)
-if test $use_builtin_memset = "yes"; then
- AC_DEFINE(HAVE_BUILTIN_MEMSET)
-fi
-AC_LANG_RESTORE
-
AC_ARG_ENABLE(debugging,
[ --enable-debugging Build a cygwin DLL which has more consistency checking for debugging],
[case "${enableval}" in