aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 22 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 89972326..92e43e5d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNU Awk], 4.1.3a, bug-gawk@gnu.org, gawk)
+AC_INIT([GNU Awk],[4.1.60],[bug-gawk@gnu.org],[gawk])
# This is a hack. Different versions of install on different systems
# are just too different. Chuck it and use install-sh.
@@ -39,7 +39,7 @@ then
export INSTALL
fi
-AC_PREREQ(2.69)
+AC_PREREQ([2.69])
AM_INIT_AUTOMAKE([1.15 dist-xz dist-lzip])
AC_CONFIG_MACRO_DIR([m4])
@@ -110,7 +110,7 @@ AC_SUBST([pkgextensiondir], ['${pkglibdir}'])
dnl checks for systems
AC_ZOS_USS
-AC_ISC_POSIX
+AC_SEARCH_LIBS([strerror],[cposix])
AC_SYS_LARGEFILE
GAWK_AC_AIX_TWEAK
GAWK_AC_LINUX_ALPHA
@@ -131,13 +131,6 @@ dnl need -D_SYSV3 for ISC
CFLAGS="$CFLAGS -D_SYSV3"
fi
-dnl check for systems where libc is borked for regex handling
-case $host_os in
-mirbsd*)
- AC_DEFINE([LIBC_IS_BORKED], 1, [libc is broken for regex handling])
- ;;
-esac
-
dnl Set the programming language for checks. Fortunately,
dnl this only needs to be set once, since everything is in C.
AC_LANG([C])
@@ -170,8 +163,7 @@ AM_CONDITIONAL([TEST_CROSS_COMPILE], [test "x$build_alias" != "x$host_alias"])
dnl checks for typedefs
AC_TYPE_PID_T
-AC_TYPE_SIGNAL
-AC_SIZE_T
+AC_TYPE_SIZE_T
AC_TYPE_GETGROUPS
AC_TYPE_LONG_LONG_INT
AC_TYPE_UNSIGNED_LONG_LONG_INT
@@ -181,30 +173,26 @@ AC_CHECK_TYPE(ssize_t, int)
AC_CHECK_SIZEOF(unsigned int)
AC_CHECK_SIZEOF(unsigned long)
dnl see if time_t is defined in <sys/types.h>
-AC_TRY_COMPILE([#include <sys/types.h>],[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>]], [[
time_t foo;
foo = 0;
-],
- AC_DEFINE(TIME_T_IN_SYS_TYPES_H, 1,
- [some systems define this type here]))
+]])],[AC_DEFINE(TIME_T_IN_SYS_TYPES_H, 1,
+ some systems define this type here)],[])
dnl check for wctype_t in <wctype.h>
-AC_TRY_COMPILE([#include <wctype.h>],[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <wctype.h>]], [[
wctype_t foo;
foo = 0;
-],
- AC_DEFINE(HAVE_WCTYPE_T, 1, [systems should define this type here]))
+]])],[AC_DEFINE(HAVE_WCTYPE_T, 1, systems should define this type here)],[])
dnl check for wint_t in <wctype.h>
-AC_TRY_COMPILE([#include <wctype.h>],[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <wctype.h>]], [[
wint_t foo;
foo = 0;
-],
- AC_DEFINE(HAVE_WINT_T, 1, [systems should define this type here]))
+]])],[AC_DEFINE(HAVE_WINT_T, 1, systems should define this type here)],[])
dnl check for sockaddr_storage
-AC_TRY_COMPILE([#include <sys/types.h>
-#include <sys/socket.h>],[
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
+#include <sys/socket.h>]], [[
struct sockaddr_storage foo;
-],
- AC_DEFINE(HAVE_SOCKADDR_STORAGE, 1, [newer systems define this type here]))
+]])],[AC_DEFINE(HAVE_SOCKADDR_STORAGE, 1, newer systems define this type here)],[])
dnl Borrwed from rsync, thanks to to Jim Meyering.
@@ -227,18 +215,18 @@ AC_DEFUN([TYPE_SOCKLEN_T],
rsync_cv_socklen_t_equiv=
for arg2 in "struct sockaddr" void; do
for t in int size_t unsigned long "unsigned long"; do
- AC_TRY_COMPILE([
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <sys/types.h>
#include <sys/socket.h>
int getpeername (int, $arg2 *, $t *);
- ],[
+ ]], [[
$t len;
getpeername(0,0,&len);
- ],[
+ ]])],[
rsync_cv_socklen_t_equiv="$t"
break
- ])
+ ],[])
done
done
@@ -286,9 +274,10 @@ esac
AC_CHECK_FUNCS(__etoa_l atexit btowc fmod getgrent getgroups grantpt \
isascii iswctype iswlower iswupper mbrlen \
memcmp memcpy memcpy_ulong memmove memset \
- memset_ulong mkstemp posix_openpt setenv setlocale setsid snprintf strchr \
+ memset_ulong mkstemp posix_openpt setenv setlocale setsid sigprocmask \
+ snprintf strchr \
strerror strftime strcasecmp strncasecmp strcoll strtod strtoul \
- system tmpfile towlower towupper tzset usleep wcrtomb \
+ system tmpfile towlower towupper tzset usleep waitpid wcrtomb \
wcscoll wctype)
dnl this check is for both mbrtowc and the mbstate_t type, which is good
AC_FUNC_MBRTOWC
@@ -420,6 +409,7 @@ AC_SUBST(GAWKLIBEXT)
AC_CONFIG_FILES(Makefile
awklib/Makefile
doc/Makefile
+ extras/Makefile
po/Makefile.in
test/Makefile)
if test "x$enable_extensions" = "xyes"; then