aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index db535963..ce25d031 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,7 +88,7 @@ AC_ARG_ENABLE([versioned-extension-dir],
# set default shared library location
AC_SUBST([pkgextensiondir], ['${pkglibdir}'${EXTENSIONDIR}])
-AC_CANONICAL_HOST
+GAWK_CANONICAL_HOST
AC_USE_SYSTEM_EXTENSIONS
dnl checks for programs
@@ -458,12 +458,10 @@ AH_BOTTOM([#include "custom.h"])
dnl Crude but small hack to make plug-ins work on Mac OS X
dnl We should really use the libtool value for shrext_cmds, but that
dnl is not available here, since we do not use libtool at the top level.
-AS_VAR_IF([EXEEXT],[.exe],[GAWKLIBEXT=dll],[
case $acl_shlibext in
dylib) GAWKLIBEXT=so ;; # MacOS uses .dylib for shared libraries, but libtool uses .so for modules
*) GAWKLIBEXT=$acl_shlibext ;;
esac
-])
AC_SUBST(GAWKLIBEXT)
AC_CONFIG_FILES(Makefile