aboutsummaryrefslogtreecommitdiffstats
path: root/extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extension/Makefile.am')
-rw-r--r--extension/Makefile.am27
1 files changed, 9 insertions, 18 deletions
diff --git a/extension/Makefile.am b/extension/Makefile.am
index ac1b7a29..bfc12472 100644
--- a/extension/Makefile.am
+++ b/extension/Makefile.am
@@ -110,9 +110,15 @@ testext_la_LIBADD = $(MY_LIBS)
install-data-hook:
for i in $(pkgextension_LTLIBRARIES) ; do \
- $(RM) $(pkgextensiondir)/$$i ; \
+ $(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \
done
+# Keep the uninstall check working:
+uninstall-so:
+ $(RM) $(pkgextensiondir)/*.so
+
+uninstall-recursive: uninstall-so
+
EXTRA_DIST = build-aux/config.rpath \
ChangeLog \
ChangeLog.0 \
@@ -122,24 +128,9 @@ EXTRA_DIST = build-aux/config.rpath \
siglist.h
dist_man_MANS = \
- filefuncs.3am fnmatch.3am fork.3am ordchr.3am \
- readdir.3am readfile.3am revoutput.3am \
+ filefuncs.3am fnmatch.3am fork.3am inplace.3am \
+ ordchr.3am readdir.3am readfile.3am revoutput.3am \
revtwoway.3am rwarray.3am time.3am
# gettext requires this
SUBDIRS =
-
-# This is an ugly hack, initially for MirBSD but probably needed for other
-# systems. If gawk doesn't have the API built in, don't try to build the
-# extensions.
-#
-# Given the workaround in configure, this isn't strictly necessary, but
-# we're leaving it in, in case of some other system needing it.
-check-recursive all-recursive: check-for-shared-lib-support
-
-check-for-shared-lib-support:
- @if ../gawk$(EXEEXT) --version | sed 1q | grep API > /dev/null; \
- then : do nothing ; \
- else echo Building the extensions is not supported on this platform ; \
- exit 1; \
- fi