aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 60b50a87..962ab6b2 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -985,7 +985,13 @@ machine-tests: $(MACHINE_TESTS)
mpfr-tests: $(MPFR_TESTS)
-shlib-tests: $(SHLIB_TESTS)
+shlib-tests:
+ @if grep 'DYNAMIC 1' $(top_srcdir)/config.h > /dev/null ; then \
+ $(MAKE) shlib-real-tests ; \
+ else echo shlib tests not supported on this system ; \
+ fi
+
+shlib-real-tests: $(SHLIB_TESTS)
msg::
@echo ''