aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 090ad0ea..e573f5e1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1031,6 +1031,10 @@ EXTRA_DIST = \
uparrfs.awk \
uparrfs.in \
uparrfs.ok \
+ watchpoint1.awk \
+ watchpoint1.in \
+ watchpoint1.ok \
+ watchpoint1.script \
wideidx.awk \
wideidx.in \
wideidx.ok \
@@ -1133,8 +1137,9 @@ GAWK_EXT_TESTS = \
splitarg4 strftime \
strtonum switch2 symtab1 symtab2 symtab3 symtab4 symtab5 symtab6 \
symtab7 symtab8 symtab9 \
- typedregex1 typedregex2 typedregex3 typeof1 typeof2 typeof3 typeof4
- timeout
+ typedregex1 typedregex2 typedregex3 typeof1 typeof2 typeof3 typeof4 \
+ timeout \
+ watchpoint1
EXTRA_TESTS = inftest regtest
@@ -2186,6 +2191,11 @@ muldimposix::
@AWKPATH="$(srcdir)" $(AWK) -f $@.awk --posix >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
@-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+watchpoint1:
+ @echo $@
+ @AWKPATH="$(srcdir)" $(AWK) -D -f $@.awk $@.in < $@.script >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
+ @-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+
# Targets generated for other tests:
include Maketests