aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c53e65c1..68ded6cd 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -770,6 +770,9 @@ EXTRA_DIST = \
readdir0.awk \
readfile2.awk \
readfile2.ok \
+ rebrackloc.awk \
+ rebrackloc.in \
+ rebrackloc.ok \
rebt8b1.awk \
rebt8b1.ok \
rebt8b2.awk \
@@ -1051,7 +1054,8 @@ BASIC_TESTS = \
paramdup paramres paramtyp paramuninitglobal parse1 parsefld parseme \
pcntplus posix2008sub prdupval prec printf0 printf1 prmarscl prmreuse \
prt1eval prtoeval \
- rand randtest range1 rebt8b1 redfilnm regeq regexpbrack regexpbrack2 regexprange regrange reindops \
+ rand randtest range1 rebrackloc rebt8b1 redfilnm regeq regexpbrack regexpbrack2 \
+ regexprange regrange reindops \
reparse resplit rri1 rs rsnul1nl rsnulbig rsnulbig2 rstest1 rstest2 \
rstest3 rstest4 rstest5 rswhite \
scalar sclforin sclifin sortempty sortglos splitargv splitarr splitdef \
@@ -2077,8 +2081,10 @@ backsmalls2:
dbugeval::
@echo $@
- @$(AWK) --debug -f /dev/null < "$(srcdir)"/$@.in > _$@ 2>&1 || echo EXIT CODE: $$? >>_$@
- @-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+ @if [ -t 0 ]; then \
+ $(AWK) --debug -f /dev/null < "$(srcdir)"/$@.in > _$@ 2>&1 || echo EXIT CODE: $$? >>_$@ ; \
+ $(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@ ; \
+ fi
printhuge::
@echo $@