summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorClaudio Fontana <sick_soul@users.sourceforge.net>2006-07-21 23:40:02 +0000
committerClaudio Fontana <sick_soul@users.sourceforge.net>2006-07-21 23:40:02 +0000
commit9a72ecd6dc36eab0497dc428d10a6ad1dd87a19a (patch)
treea528fd617cda36f619bc076429b0995bcda12e2c /lib/Makefile.am
parentee29ecd605b329c38ab4c6c6c89d6288693495de (diff)
downloadidutils-9a72ecd6dc36eab0497dc428d10a6ad1dd87a19a.tar.gz
idutils-9a72ecd6dc36eab0497dc428d10a6ad1dd87a19a.tar.bz2
idutils-9a72ecd6dc36eab0497dc428d10a6ad1dd87a19a.zip
* upgraded gnulib
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am56
1 files changed, 52 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 1b346fd..6a13fa1 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,14 +1,14 @@
## Process this file with automake to produce Makefile.in.
-# Copyright (C) 2004 Free Software Foundation, Inc.
+# Copyright (C) 2004-2006 Free Software Foundation, Inc.
#
# This file is free software, distributed under the terms of the GNU
# General Public License. As a special exception to the GNU General
# Public License, this file may be distributed as part of a program
-# that contains a configuration script generated by Automake, under
+# that contains a configuration script generated by Autoconf, under
# the same distribution terms as the rest of that program.
#
# Generated by gnulib-tool.
-# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=lib --m4-base=m4 --aux-dir=. --macro-prefix=gl alloca alloca-opt atexit closeout dirname error exclude exit exitfail extensions fnmatch fnmatch-gnu fpending getcwd getopt gettext gettext-h havelib inttostr lstat malloc mbchar mbuiter memchr memcpy mempcpy memset obstack pathmax quotearg realloc regex restrict stat-macros stdbool strcase strcspn strdup strnlen1 strpbrk strsep strstr xalloc xalloc-die xgetcwd
+# Reproduce by: gnulib-tool --import --dir=. --lib=libgnu --source-base=lib --m4-base=m4 --doc-base=doc --aux-dir=. --macro-prefix=gl --assume-autoconf=2.59 alloca alloca-opt atexit closeout dirname error exclude exit exitfail extensions fnmatch fnmatch-gnu fpending getcwd getopt gettext gettext-h havelib inttostr lstat malloc mbchar mbuiter memchr memcpy mempcpy memset obstack pathmax quotearg realloc regex restrict stat-macros stdbool strcase strcspn strdup strnlen1 strpbrk strsep strstr xalloc xalloc-die xgetcwd
AUTOMAKE_OPTIONS = 1.5 gnits no-dependencies
@@ -16,16 +16,18 @@ noinst_LIBRARIES = libgnu.a
libgnu_a_SOURCES =
libgnu_a_LIBADD = @LIBOBJS@
-AM_CPPFLAGS =
noinst_HEADERS =
EXTRA_DIST =
BUILT_SOURCES =
SUFFIXES =
MOSTLYCLEANFILES =
+MOSTLYCLEANDIRS =
CLEANFILES =
DISTCLEANFILES =
MAINTAINERCLEANFILES =
+AM_CPPFLAGS =
+
## begin gnulib module alloca
@@ -88,6 +90,14 @@ MOSTLYCLEANFILES += getopt.h getopt.h-t
## begin gnulib module gettext
+# This is for those projects which use "gettextize --intl" to put a source-code
+# copy of libintl into their package. In such projects, every Makefile.am needs
+# -I$(top_builddir)/intl, so that <libintl.h> can be found in this directory.
+# For the Makefile.ams in other directories it is the maintainer's
+# responsibility; for the one from gnulib we do it here.
+# This option has no effect when the user disables NLS (because then the intl
+# directory contains no libintl.h file) or when the project does not use
+# "gettextize --intl".
AM_CPPFLAGS += -I$(top_builddir)/intl
## end gnulib module gettext
@@ -98,6 +108,12 @@ libgnu_a_SOURCES += gettext.h
## end gnulib module gettext-h
+## begin gnulib module intprops
+
+EXTRA_DIST += intprops.h
+
+## end gnulib module intprops
+
## begin gnulib module inttostr
EXTRA_DIST += inttostr.c
@@ -160,17 +176,49 @@ libgnu_a_SOURCES += strstr.h
## end gnulib module strstr
+## begin gnulib module unistd
+
+BUILT_SOURCES += $(UNISTD_H)
+
+# We need the following in order to create an empty placeholder for
+# <unistd.h> when the system doesn't have one.
+unistd.h:
+ echo '/* Empty placeholder for $@. */' >$@
+MOSTLYCLEANFILES += unistd.h
+
+## end gnulib module unistd
+
## begin gnulib module verify
libgnu_a_SOURCES += verify.h
## end gnulib module verify
+## begin gnulib module wcwidth
+
+libgnu_a_SOURCES += wcwidth.h
+
+## end gnulib module wcwidth
+
## begin gnulib module xalloc-die
libgnu_a_SOURCES += xalloc-die.c
## end gnulib module xalloc-die
+## begin gnulib module xstrndup
+
+libgnu_a_SOURCES += xstrndup.h xstrndup.c
+
+## end gnulib module xstrndup
+
+
+mostlyclean-local:
+ @test -z "$(MOSTLYCLEANDIRS)" || \
+ for dir in $(MOSTLYCLEANDIRS); do \
+ if test -d $$dir; then \
+ echo "rmdir $$dir"; rmdir $$dir; \
+ fi; \
+ done
# Makefile.am ends here