summaryrefslogtreecommitdiffstats
path: root/libidu/Makefile.am
diff options
context:
space:
mode:
authorGreg McGary <greg@mcgary.org>1997-04-18 06:43:32 +0000
committerGreg McGary <greg@mcgary.org>1997-04-18 06:43:32 +0000
commit916418ea1284e6aa64f50eba077e48ced5944acc (patch)
tree8e519e3a48ae80c8c17da3ba5acccd91530b22ff /libidu/Makefile.am
parenta560adff07afe7c1f35e4585e0694e89c842b245 (diff)
downloadidutils-916418ea1284e6aa64f50eba077e48ced5944acc.tar.gz
idutils-916418ea1284e6aa64f50eba077e48ced5944acc.tar.bz2
idutils-916418ea1284e6aa64f50eba077e48ced5944acc.zip
Initial revision
Diffstat (limited to 'libidu/Makefile.am')
-rw-r--r--libidu/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/libidu/Makefile.am b/libidu/Makefile.am
new file mode 100644
index 0000000..5fde198
--- /dev/null
+++ b/libidu/Makefile.am
@@ -0,0 +1,22 @@
+## Process this file with automake to create Makefile.in
+
+AUTOMAKE_OPTIONS = ansi2knr
+
+noinst_LIBRARIES = idu
+
+idu_SOURCES = dynvec.c hash.c idfile.c idread.c idwrite.c fnprint.c \
+ scanners.c walker.c
+
+idudir = $(prefix)/share
+idu_DATA = id-lang.map
+
+noinst_HEADERS = dynvec.h hash.h idfile.h scanners.h tokflags.h xnls.h
+
+INCLUDES = -I. -I$(srcdir) \
+ -I../lib -I$(top_srcdir)/lib \
+ -I../intl -I$(top_srcdir)/intl \
+ -I.. -I$(top_srcdir)
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
+ansi2knr.c: $(top_srcdir)/src/ansi2knr.c
+ ln $(top_srcdir)/src/ansi2knr.c .