summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c353487..f563f09 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,7 @@ AC_CONFIG_HEADER(config.h)
PRODUCT=mkid
MAJOR_VERSION=3
MINOR_VERSION=0
-PATCH_LEVEL=4
+PATCH_LEVEL=5
OLD_PATCH_LEVEL=`expr $PATCH_LEVEL - 1`
VERSION=$MAJOR_VERSION.$MINOR_VERSION
FULL_VERSION=$VERSION.$PATCH_LEVEL
@@ -39,7 +39,7 @@ AC_HEADER_STDC
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(limits.h stddef.h sys/types.h sys/stat.h sys/param.h)
AC_CHECK_HEADERS(stdlib.h unistd.h string.h malloc.h memory.h assert.h ctype.h errno.h)
-AC_CHECK_HEADERS(sys/ioctl.h termios.h termio.h sgttyb.h)
+AC_CHECK_HEADERS(sys/ioctl.h termios.h termio.h sgttyb.h regex.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -47,6 +47,10 @@ fp_C_PROTOTYPES
AC_TYPE_SIGNAL
AC_TYPE_OFF_T
AC_TYPE_SIZE_T
+AC_CHECK_SIZEOF(int)
+AC_CHECK_SIZEOF(long)
+AC_CHECK_SIZEOF(short)
+AC_CHECK_SIZEOF(char)
CFLAGS=${CFLAGS--g}
LDFLAGS=${LDFLAGS--g}
@@ -55,9 +59,10 @@ AC_SUBST(LDFLAGS)
dnl Checks for library functions.
AC_PROG_GCC_TRADITIONAL
-AC_CHECK_FUNCS(getwd getcwd getopt_long re_comp)
+AC_CHECK_FUNCS(getwd getcwd getopt_long)
AC_CHECK_FUNCS(strdup strchr strrchr strcasecmp strerror)
AC_CHECK_FUNCS(memcpy bcopy memset bzero)
+AC_CHECK_FUNCS(regcomp regcmp re_comp)
AC_FUNC_ALLOCA
AC_SUBST(ALLOCA)
if test "$ac_cv_func_re_comp" = no; then REGEXP="regex.o"; fi