summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am32
1 files changed, 13 insertions, 19 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 520f05e..4d67679 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,28 +1,22 @@
## Process this file with automake to create Makefile.in
-AUTOMAKE_OPTIONS = ansi2knr
+noinst_LIBRARIES = sys
-noinst_LIBRARIES = idu
+EXTRA_DIST = alloca.c basename.c dirname.c error.c fnmatch.c getopt.c \
+ getopt1.c memcpy.c memset.c obstack.c regex.c rx.c \
+ strcasecmp.c strcspn.c strdup.c strndup.c strpbrk.c strspn.c \
+ strstr.c strtok.c
-EXTRA_DIST = alloca.c error.c getopt.c getopt1.c regex.c rx.c \
- strcasecmp.c strdup.c strndup.c strtok.c \
- obstack.c basename.c dirname.c fnmatch.c \
- ansi2knr.1 ansi2knr.c
+sys_SOURCES = xgetcwd.c xmalloc.c
-idu_SOURCES = misc.c scanners.c idfile.c filenames.c bitops.c token.c \
- idwalk.c hash.c dynvec.c xmalloc.c xgetcwd.c
-
-idudir = $(prefix)/share
-idu_DATA = language.map
-
-noinst_HEADERS = alloc.h bitops.h error.h filenames.h getopt.h idarg.h \
- idfile.h misc.h regex.h rx.h scanners.h strxtra.h \
- token.h system.h hash.h obstack.h pathmax.h dynvec.h \
- xmalloc.h fnmatch.h ansidecl.h
+noinst_HEADERS = ansidecl.h error.h fnmatch.h getopt.h obstack.h \
+ pathmax.h regex.h rx.h xalloca.h xdirent.h xfnmatch.h \
+ xmalloc.h xobstack.h xstddef.h xstdlib.h xstring.h xsysstat.h \
+ xunistd.h
+
INCLUDES = -I. -I$(srcdir) \
- -I../lib -I$(top_srcdir)/lib \
-I../intl -I$(top_srcdir)/intl \
-I.. -I$(top_srcdir)
-DEFS = -DLOCALEDIR=\"$(localedir)\" -DLANGUAGE_MAP=\"$(idudir)/language.map\" @DEFS@
-idu_LIBADD = @REGEXOBJ@ @LIBOBJS@ @ALLOCA@
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+sys_LIBADD = @REGEXOBJ@ @LIBOBJS@ @ALLOCA@