summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..3d1b163
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,19 @@
+## Process this file with automake to create Makefile.in
+
+AUTOMAKE_OPTIONS = ansi2knr
+
+bin_PROGRAMS = mkid lid fid idx
+bin_SCRIPTS = eid aid gid pid defid
+
+EXTRA_DIST = ansi2knr.1 ansi2knr.c $(bin_SCRIPTS)
+
+localedir = $(datadir)/locale
+
+INCLUDES = -I. -I$(srcdir) \
+ -I../lib -I$(top_srcdir)/lib \
+ -I../intl -I$(top_srcdir)/intl \
+ -I.. -I$(top_srcdir)
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+LDADD = @INTLLIBS@ ../lib/libidu.a
+
+$(PROGRAMS): $(LDADD)