summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2013-02-21 11:29:22 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2013-02-21 11:29:22 +0100
commit212af677576238bf87deb1bee3e7bcfb170dc668 (patch)
treed12f71316c3fd3901a899d1bee1210969cea8ea8 /runtime/Makefile.am
parent3cc89eb96923cb85654558ce623256f4da76b87f (diff)
downloadrsyslog-212af677576238bf87deb1bee3e7bcfb170dc668.tar.gz
rsyslog-212af677576238bf87deb1bee3e7bcfb170dc668.tar.bz2
rsyslog-212af677576238bf87deb1bee3e7bcfb170dc668.zip
logsigner: sign via merkle tree approach (still PoC, non production)
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index fbc92d9c..0f1b580a 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -1,6 +1,6 @@
sbin_PROGRAMS =
man_MANS =
-noinst_LTLIBRARIES = librsyslog.la
+noinst_LTLIBRARIES = librsyslog.la librsgt.la
pkglib_LTLIBRARIES =
#pkglib_LTLIBRARIES = librsyslog.la
@@ -92,6 +92,7 @@ librsyslog_la_SOURCES = \
../template.h
# the files with ../ we need to work on - so that they either become part of the
# runtime or will no longer be needed. -- rgerhards, 2008-06-13
+#
if WITH_MODDIRS
librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(PTHREADS_CFLAGS) $(LIBEE_CFLAGS) -I\$(top_srcdir)/tools
@@ -172,6 +173,14 @@ lmnsd_gtls_la_LDFLAGS = -module -avoid-version
lmnsd_gtls_la_LIBADD = $(GNUTLS_LIBS)
endif
+#
+# support library for guardtime
+#
+if ENABLE_GUARDTIME
+ librsgt_la_SOURCES = librsgt.c
+endif
+
+
update-systemd:
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.h > sd-daemon.h