summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-06-06 16:41:55 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2011-06-06 16:41:55 +0200
commit2b9e5ac193ea91817ff17851a4a16a42a5b87fdb (patch)
tree207ffb12ed68bc729ac9809b69cc00552c598037 /runtime/Makefile.am
parent223b103ccca416effbed2d61798e4aad7d421cc3 (diff)
downloadrsyslog-2b9e5ac193ea91817ff17851a4a16a42a5b87fdb.tar.gz
rsyslog-2b9e5ac193ea91817ff17851a4a16a42a5b87fdb.tar.bz2
rsyslog-2b9e5ac193ea91817ff17851a4a16a42a5b87fdb.zip
added a first implementation of a DNS name cache
this still has a couple of weaknesses, like no size limit, no expiration of entries, suboptimal algorithms -- but it should perform better than what we had previously. Implementation will be improved based on feedback during the next couple of releases
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index a107e21a..232d8f03 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -8,6 +8,8 @@ librsyslog_la_SOURCES = \
rsyslog.c \
rsyslog.h \
typedefs.h \
+ dnscache.c \
+ dnscache.h \
unicode-helper.h \
atomic.h \
batch.h \