summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2013-03-22 14:41:22 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2013-03-22 14:41:22 +0100
commitfde16430b18748162d9795e90f017569c3b81ad7 (patch)
treee5805adac6a99f46edc84e54bc4b3f128aa676e1 /runtime/Makefile.am
parent3e8ab2d389e802df8ec28b36ebe3f968e760b2db (diff)
parente25ffb6d1839d35fa890099aef8a78930d90438d (diff)
downloadrsyslog-fde16430b18748162d9795e90f017569c3b81ad7.tar.gz
rsyslog-fde16430b18748162d9795e90f017569c3b81ad7.tar.bz2
rsyslog-fde16430b18748162d9795e90f017569c3b81ad7.zip
Merge branch 'master-gt'
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index fbc92d9c..c429394d 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -1,6 +1,6 @@
sbin_PROGRAMS =
man_MANS =
-noinst_LTLIBRARIES = librsyslog.la
+noinst_LTLIBRARIES = librsyslog.la librsgt.la
pkglib_LTLIBRARIES =
#pkglib_LTLIBRARIES = librsyslog.la
@@ -17,6 +17,7 @@ librsyslog_la_SOURCES = \
module-template.h \
im-helper.h \
obj-types.h \
+ sigprov.h \
nsd.h \
glbl.h \
glbl.c \
@@ -92,6 +93,7 @@ librsyslog_la_SOURCES = \
../template.h
# the files with ../ we need to work on - so that they either become part of the
# runtime or will no longer be needed. -- rgerhards, 2008-06-13
+#
if WITH_MODDIRS
librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(PTHREADS_CFLAGS) $(LIBEE_CFLAGS) -I\$(top_srcdir)/tools
@@ -172,6 +174,20 @@ lmnsd_gtls_la_LDFLAGS = -module -avoid-version
lmnsd_gtls_la_LIBADD = $(GNUTLS_LIBS)
endif
+#
+# support library for guardtime
+#
+if ENABLE_GUARDTIME
+ librsgt_la_SOURCES = librsgt.c librsgt_read.c
+
+ pkglib_LTLIBRARIES += lmsig_gt.la
+ lmsig_gt_la_SOURCES = lmsig_gt.c
+ lmsig_gt_la_CPPFLAGS = $(RSRT_CFLAGS) $(GUARDTIME_CFLAGS)
+ lmsig_gt_la_LDFLAGS = -module -avoid-version
+ lmsig_gt_la_LIBADD = librsgt.la $(GUARDTIME_LIBS)
+endif
+
+
update-systemd:
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.c > sd-daemon.c
curl http://cgit.freedesktop.org/systemd/plain/src/sd-daemon.h > sd-daemon.h