aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorjohn haque <j.eh@mchsi.com>2012-02-14 08:13:19 -0600
committerjohn haque <j.eh@mchsi.com>2012-02-14 08:13:19 -0600
commit06a6f16495e2a3d0cb664fc473107d3cdbe6f11e (patch)
treee9cd44bcd2ea18759036e894c09199378f960c2d /Makefile.am
parentcd44d957787e162df4348028c22e8b9621000790 (diff)
downloadegawk-06a6f16495e2a3d0cb664fc473107d3cdbe6f11e.tar.gz
egawk-06a6f16495e2a3d0cb664fc473107d3cdbe6f11e.tar.bz2
egawk-06a6f16495e2a3d0cb664fc473107d3cdbe6f11e.zip
Add infrastructure for MPFR/GMP support.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b9470617..4e483e4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -110,6 +110,7 @@ base_sources = \
io.c \
mbsupport.h \
main.c \
+ mpfr.c \
msg.c \
node.c \
profile.c \
@@ -128,7 +129,7 @@ base_sources = \
gawk_SOURCES = $(base_sources)
# Get extra libs as needed, Automake will supply LIBINTL and SOCKET_LIBS.
-LDADD = $(LIBSIGSEGV) $(LIBINTL) $(SOCKET_LIBS) @LIBREADLINE@
+LDADD = $(LIBSIGSEGV) $(LIBINTL) $(SOCKET_LIBS) @LIBREADLINE@ -lmpfr -lgmp
# Directory for gawk's data files. Automake supplies datadir.
pkgdatadir = $(datadir)/awk