aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2018-05-13 11:30:28 -0400
committerArnold D. Robbins <arnold@skeeve.com>2018-05-13 11:30:28 -0400
commit525c2d59a50d5814f42a9335a0c64376afa71409 (patch)
tree317d85969616e90ab06dca183c2044fcea0cfd12 /Makefile.am
parent85c609c42657b36dbfbde7528d9d6fd998da0fe4 (diff)
downloadegawk-525c2d59a50d5814f42a9335a0c64376afa71409.tar.gz
egawk-525c2d59a50d5814f42a9335a0c64376afa71409.tar.bz2
egawk-525c2d59a50d5814f42a9335a0c64376afa71409.zip
Major improvements to test infrastructure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0089b862..b9362944 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -169,7 +169,7 @@ check-local: gawk$(EXEEXT)
# A little extra clean up when making distributions.
# And additional set up for the pc directory.
-dist-hook:
+dist-hook: pc/Makefile.tst
cd "$(distdir)"/extension ; rm -f *.o *.so
cd "$(srcdir)"/pc ; \
chmod u+w config.h ; \
@@ -191,6 +191,9 @@ command.c: command.y
$(YACC) -o $@ -p zz $<
sed 's/parse error/syntax error/g' < $@ > $@.tmp && mv $@.tmp $@
+pc/Makefile.tst: test/Makefile.in
+ cd pc && awk -f GenMakefileTst.awk ../test/Makefile.in > Makefile.tst
+
# This is for my development & testing.
efence: gawk
$(CC) $(LDFLAGS) -o gawk $$(ls *.o | grep -v '_p.o$$') $(LDADD) $(LIBS) -lefence