aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew J. Schorr <aschorr@telemetry-investments.com>2012-07-25 12:48:37 -0400
committerAndrew J. Schorr <aschorr@telemetry-investments.com>2012-07-25 12:48:37 -0400
commit0fff60287fb9cc41288b3373f47031ab3dd597ac (patch)
tree91357fd5a4312af8ba6de29c4f60d7063f3ae0ca /configure.ac
parent502050948a347ef5c618886cec1b83357ad7ac3f (diff)
downloadegawk-0fff60287fb9cc41288b3373f47031ab3dd597ac.tar.gz
egawk-0fff60287fb9cc41288b3373f47031ab3dd597ac.tar.bz2
egawk-0fff60287fb9cc41288b3373f47031ab3dd597ac.zip
Minor configure.ac/Makefile.am change for more elegant shared library support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a45e5c4e..f3cf6777 100644
--- a/configure.ac
+++ b/configure.ac
@@ -357,9 +357,13 @@ AC_CONFIG_HEADERS([config.h:configh.in])
AH_BOTTOM([#include "custom.h"])
dnl Crude but small hack to make plug-ins work on Mac OS X
+dnl We should really use the libtool value for shrext_cmds, but that
+dnl is not available here, since we do not use libtool at the top level.
case $acl_shlibext in
-dylib) acl_shlibext=so ;; # force it
+dylib) GAWKLIBEXT=so ;; # MacOS uses .dylib for shared libraries, but libtool uses .so for modules
+*) GAWKLIBEXT=$acl_shlibext ;;
esac
+AC_SUBST(GAWKLIBEXT)
AC_CONFIG_FILES(Makefile
awklib/Makefile