aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2017-04-20 05:58:35 +0300
committerArnold D. Robbins <arnold@skeeve.com>2017-04-20 05:58:35 +0300
commit780c96b8a827fd1780e611cd41d59d80033eff46 (patch)
tree191e174567c4f5e692c06550a068f4fcd3be4819 /configure.ac
parent67f4d070335e12622af1363b71c68489c64f5bc7 (diff)
downloadegawk-780c96b8a827fd1780e611cd41d59d80033eff46.tar.gz
egawk-780c96b8a827fd1780e611cd41d59d80033eff46.tar.bz2
egawk-780c96b8a827fd1780e611cd41d59d80033eff46.zip
Fix 64-bit compilation without MPFR.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 338973b2..011532f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,7 +46,7 @@ AC_CONFIG_MACRO_DIR([m4])
dnl Additional argument stuff
AC_ARG_WITH(whiny-user-strftime,
- [AS_HELP_STRING([--with-whiny-user-strftime], [Force use of included version of strftime for deficient systems])],
+ [AS_HELP_STRING([--with-whiny-user-strftime], [force use of included version of strftime for deficient systems])],
if test "$withval" = yes
then
AC_DEFINE(USE_INCLUDED_STRFTIME, 1,
@@ -54,20 +54,29 @@ AC_ARG_WITH(whiny-user-strftime,
fi
)
AC_ARG_ENABLE([lint],
- [AS_HELP_STRING([--disable-lint],[Disable gawk lint checking])],
+ [AS_HELP_STRING([--disable-lint],[do not compile in gawk lint checking])],
if test "$enableval" = no
then
AC_DEFINE(NO_LINT, 1, [disable lint checks])
fi
)
AC_ARG_ENABLE([severe-portability-problems],
- [AS_HELP_STRING([--enable-severe-portability-problems],[Enable really nasty portability problems])],
+ [AS_HELP_STRING([--enable-severe-portability-problems],[allow really nasty portability problems])],
if test "$enableval" = yes
then
AC_DEFINE(I_DONT_KNOW_WHAT_IM_DOING, 1, [enable severe portability problems])
fi
)
+SKIP_MPFR=no
+AC_ARG_ENABLE([mpfr],
+ [AS_HELP_STRING([--disable-mpfr],[do not check for MPFR])],
+ if test "$enableval" = no
+ then
+ SKIP_MPFR=yes
+ fi
+)
+
AC_CANONICAL_HOST
AC_USE_SYSTEM_EXTENSIONS
@@ -380,7 +389,10 @@ case `uname -m` in
*'Power Macintosh'*)
: ;;
*)
- GNUPG_CHECK_MPFR
+ case $SKIP_MPFR in
+ no) GNUPG_CHECK_MPFR
+ ;;
+ esac
;;
esac