aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2010-07-16 12:57:07 +0300
committerArnold D. Robbins <arnold@skeeve.com>2010-07-16 12:57:07 +0300
commit3ca7f0b16d0a5c105380b284a81c6a1b2c210908 (patch)
treec2153d226b9cba3ebca0c3556b19bf3e52cd20dd /configure.in
parentf20ab7c3039a4023f41372bfe4bde3b16d481df7 (diff)
downloadegawk-3ca7f0b16d0a5c105380b284a81c6a1b2c210908.tar.gz
egawk-3ca7f0b16d0a5c105380b284a81c6a1b2c210908.tar.bz2
egawk-3ca7f0b16d0a5c105380b284a81c6a1b2c210908.zip
Move to gawk-3.0.5.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7c0cf914..7867034f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl configure.in --- autoconf input file for gawk
dnl
-dnl Copyright (C) 1995-1999 the Free Software Foundation, Inc.
+dnl Copyright (C) 1995-2000 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -30,7 +30,6 @@ dnl This is the configure.in script proper
AC_INIT(awk.h)
AC_PREREQ(2.12)
AC_CONFIG_HEADER(config.h:configh.in)
-AC_CANONICAL_HOST
dnl Additional argument stuff
AC_ARG_ENABLE(bitops, [ --enable-bitops Enable Octal and Hex constants and bit functions], AC_DEFINE(BITOPS))
@@ -60,15 +59,23 @@ dnl go for speed, not debugging. :-)
CFLAGS="-O"
fi
fi
-AC_SUBST(CFLAGS)
-dnl check for Solaris (or other) large file support
-GAWK_AC_SYS_LARGEFILE
+# This is mainly for my use during testing and development.
+# Yes, it's a bit of a hack.
+if test -f $srcdir/.developing
+then
+ AC_DEFINE(BITOPS)
+ AC_DEFINE(NONDECDATA)
+ CFLAGS="$CFLAGS -DARRAYDEBUG"
+fi
+
+AC_SUBST(CFLAGS)
dnl checks for systems
AC_AIX
AC_ISC_POSIX
AC_MINIX
+GAWK_AC_SYS_LARGEFILE
GAWK_AC_AIX_TWEAK
if test "$ISC" = 1 # will be set by test for ISC