aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2010-07-16 12:49:45 +0300
committerArnold D. Robbins <arnold@skeeve.com>2010-07-16 12:49:45 +0300
commit6607eb3d5e40b98d2acc8f6b0d6a0b5a4b0f56bd (patch)
treec1eb39be8cc5c19101385e171ec0c58f95d521cc /configure.in
parent6719bb6e1c5576e857ab6fc121ec31a75161a3e7 (diff)
downloadegawk-6607eb3d5e40b98d2acc8f6b0d6a0b5a4b0f56bd.tar.gz
egawk-6607eb3d5e40b98d2acc8f6b0d6a0b5a4b0f56bd.tar.bz2
egawk-6607eb3d5e40b98d2acc8f6b0d6a0b5a4b0f56bd.zip
Move to gawk-3.0.3.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index c5a9661c..27d10b85 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl configure.in --- autoconf input file for gawk
dnl
-dnl Copyright (C) 1995, 96 the Free Software Foundation, Inc.
+dnl Copyright (C) 1995-1997 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -31,6 +31,10 @@ AC_INIT(awk.h)
AC_PREREQ(2.12)
AC_CONFIG_HEADER(config.h:configh.in)
+dnl Additional argument stuff
+AC_ARG_ENABLE(bitops, [ --enable-bitops Enable Octal and Hex constants and bit functions], AC_DEFINE(BITOPS))
+AC_ARG_ENABLE(non-decimal-data, [ --enable-non-decimal-data Enable Octal and Hex constants as valid input data], AC_DEFINE(NONDECDATA))
+
dnl checks for programs
AC_PROG_YACC
AC_PROG_LN_S
@@ -99,7 +103,17 @@ dnl see if we have mmap
AC_FUNC_MMAP
dnl check for how to use getpgrp
-AC_FUNC_GETPGRP
+dnl have to hardwire it for VMS POSIX. Sigh.
+if (uname) > /dev/null 2>&1
+then
+ case `uname` in
+ *VMS*) AC_DEFINE(GETPGRP_VOID) ;;
+ *) AC_FUNC_GETPGRP
+ ;;
+ esac
+else
+ AC_FUNC_GETPGRP
+fi
dnl checks for structure members
AC_STRUCT_ST_BLKSIZE