aboutsummaryrefslogtreecommitdiffstats
path: root/extension/CMakeLists.txt
diff options
context:
space:
mode:
authorJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-02-17 16:31:08 +0100
committerJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-02-17 16:31:08 +0100
commita5f1cf2beb31002f3cd35bfef7cb8af8843fc2b5 (patch)
treebc2a073a43f9d2ef7c7e3351cd693fda95e05d0c /extension/CMakeLists.txt
parent08fc54511a406a767652b617f9c8e293e794258a (diff)
downloadegawk-a5f1cf2beb31002f3cd35bfef7cb8af8843fc2b5.tar.gz
egawk-a5f1cf2beb31002f3cd35bfef7cb8af8843fc2b5.tar.bz2
egawk-a5f1cf2beb31002f3cd35bfef7cb8af8843fc2b5.zip
Moved all configuration stuff into cmake/configure.cmake so that config.h contains all settings. All 265 basic test cases pass now with USE_CONFIG_H set to ON.
Diffstat (limited to 'extension/CMakeLists.txt')
-rw-r--r--extension/CMakeLists.txt13
1 files changed, 3 insertions, 10 deletions
diff --git a/extension/CMakeLists.txt b/extension/CMakeLists.txt
index 9013bda3..31ae4fad 100644
--- a/extension/CMakeLists.txt
+++ b/extension/CMakeLists.txt
@@ -35,8 +35,6 @@ ENDMACRO(BuildExtension)
BuildExtension(filefuncs filefuncs.c stack.c gawkfts.c)
-DefineFunctionIfAvailable(fnmatch HAVE_FNMATCH)
-DefineHFileIfAvailable(fnmatch.h HAVE_FNMATCH_H)
if (${HAVE_FNMATCH} AND ${HAVE_FNMATCH_H})
BuildExtension(fnmatch fnmatch.c)
else()
@@ -44,10 +42,11 @@ else()
endif()
BuildExtension(fork fork.c)
+
BuildExtension(inplace inplace.c)
+
BuildExtension(ordchr ordchr.c)
-DefineHFileIfAvailable(dirent.h HAVE_DIRENT_H)
if (${HAVE_DIRENT_H})
BuildExtension(readdir readdir.c)
else()
@@ -55,9 +54,9 @@ else()
endif()
BuildExtension(readfile readfile.c)
+
BuildExtension(revoutput revoutput.c)
-DefineFunctionIfAvailable(getdtablesize HAVE_GETDTABLESIZE)
if (${HAVE_GETDTABLESIZE})
BuildExtension(revtwoway revtwoway.c)
else()
@@ -66,12 +65,6 @@ endif()
BuildExtension(rwarray rwarray.c)
-DefineFunctionIfAvailable(select HAVE_SELECT)
-DefineFunctionIfAvailable(gettimeofday HAVE_GETTIMEOFDAY)
-DefineHFileIfAvailable(sys/select.h HAVE_SYS_SELECT_H)
-DefineFunctionIfAvailable(nanosleep HAVE_NANOSLEEP)
-DefineHFileIfAvailable(time.h HAVE_TIME_H)
-DefineFunctionIfAvailable(GetSystemTimeAsFileTime HAVE_GETSYSTEMTIMEASFILETIME)
BuildExtension(time time.c)
BuildExtension(testext testext.c)