aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2012-11-06 22:26:05 +0200
committerArnold D. Robbins <arnold@skeeve.com>2012-11-06 22:26:05 +0200
commitb1f42bdc87249e1869d13df2cacaa3aceea6fc1e (patch)
tree4bc0e7d66012b854a24686685af991d811f0663a /extension/configure.ac
parent2f8505ba759663f2c4a3e5b34471851025337df6 (diff)
downloadegawk-b1f42bdc87249e1869d13df2cacaa3aceea6fc1e.tar.gz
egawk-b1f42bdc87249e1869d13df2cacaa3aceea6fc1e.tar.bz2
egawk-b1f42bdc87249e1869d13df2cacaa3aceea6fc1e.zip
Add extra debug stuff in extension/configure.ac.
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index d0e45c94..92ac10d8 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -49,6 +49,18 @@ then
CFLAGS="$CFLAGS -Wall -Wextra"
fi
+AC_MSG_CHECKING([for special development options])
+if test -f $srcdir/.developing
+then
+ if test "$GCC" = yes
+ then
+ CFLAGS="$CFLAGS -Wall -fno-builtin -g3 -gdwarf-2"
+ fi
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
AC_CHECK_HEADERS(dirent.h fnmatch.h time.h sys/time.h sys/select.h)
AC_CHECK_FUNCS(fdopendir fnmatch gettimeofday \