aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2022-02-09 07:35:02 +0200
committerArnold D. Robbins <arnold@skeeve.com>2022-02-09 07:35:02 +0200
commit0b94b68387b85310b7104bb669d7b698e92888d2 (patch)
treefa8ac12d69a31fad1c6fa1c689412e8286069ce7 /test/Makefile.am
parent128a6b43506a530a44777c1156ba1940c4d8fba0 (diff)
downloadegawk-0b94b68387b85310b7104bb669d7b698e92888d2.tar.gz
egawk-0b94b68387b85310b7104bb669d7b698e92888d2.tar.bz2
egawk-0b94b68387b85310b7104bb669d7b698e92888d2.zip
Add tests for indirect calls of builtins.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index abd1fc00..424aaa82 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -567,6 +567,8 @@ EXTRA_DIST = \
include.ok \
indirectbuiltin.awk \
indirectbuiltin.ok \
+ indirectbuiltin2.awk \
+ indirectbuiltin2.ok \
indirectcall2.awk \
indirectcall2.ok \
indirectcall.awk \
@@ -1449,6 +1451,7 @@ GAWK_EXT_TESTS = \
gnuops2 gnuops3 gnureops gsubind icasefs icasers id igncdym igncfs \
ignrcas2 ignrcas4 ignrcase incdupe incdupe2 incdupe3 incdupe4 \
incdupe5 incdupe6 incdupe7 include include2 indirectbuiltin \
+ indirectbuiltin2 \
indirectcall indirectcall2 inf-nan-torture intarray iolint \
isarrayunset lint lintexp lintindex lintint lintlength lintplus \
lintold lintset lintwarn manyfiles match1 match2 match3 mbstr1 \
@@ -2489,6 +2492,13 @@ argcasfile:
@-$(AWK) -f "$(srcdir)"/$@.awk ARGC=1 ' /no/such/file' < "$(srcdir)/$@.in" >_$@ 2>&1 || echo EXIT CODE: $$? >>_$@
@-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+indirectbuiltin2:
+ @echo $@
+ @-for test in 0 1 2 3 4 5 ; do \
+ $(AWK) -v test=$$test -f "$(srcdir)"/$@.awk ; \
+ done > _$@ 2>&1 || exit 0
+ @-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+
# Targets generated for other tests:
include Maketests