aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2021-08-13 17:03:19 -0400
committerArnold D. Robbins <arnold@skeeve.com>2021-08-13 17:03:19 -0400
commitbcc0594e9b64c89b56e8ea6891c0a9f8b97c57d1 (patch)
treea9b1274d4c91673b6da697f31d82177b16538913 /test/Makefile.am
parent492c24d65f760edea1f9228260930728eb747cf7 (diff)
downloadegawk-bcc0594e9b64c89b56e8ea6891c0a9f8b97c57d1.tar.gz
egawk-bcc0594e9b64c89b56e8ea6891c0a9f8b97c57d1.tar.bz2
egawk-bcc0594e9b64c89b56e8ea6891c0a9f8b97c57d1.zip
Rationalize strong regex as param to sub/gsub. Add tests.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 3f9e9308..7ee23813 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1057,6 +1057,8 @@ EXTRA_DIST = \
regexpbrack2.ok \
regexprange.awk \
regexprange.ok \
+ regexsub.awk \
+ regexsub.ok \
reginttrad.awk \
reginttrad.ok \
regnul1.awk \
@@ -1456,7 +1458,7 @@ GAWK_EXT_TESTS = \
procinfs profile0 profile1 profile2 profile3 profile4 profile5 profile6 \
profile7 profile8 profile9 profile10 profile11 profile12 profile13 \
profile14 profile15 pty1 pty2 \
- rebuf regnul1 regnul2 regx8bit reginttrad reint reint2 rsgetline rsglstdin \
+ rebuf regexsub regnul1 regnul2 regx8bit reginttrad reint reint2 rsgetline rsglstdin \
rsstart1 rsstart2 rsstart3 rstest6 \
sandbox1 shadow shadowbuiltin sortfor sortfor2 sortu \
sourcesplit split_after_fpat \