summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-02-27 23:11:21 +0100
committerJim Meyering <meyering@redhat.com>2008-03-03 00:24:36 +0100
commita016e88bcdcabe947bfb9dea474df5fbe2081b65 (patch)
tree5d7d7efb19e0d5f9b90fde1885a4553aa93e6d37 /Makefile.am
parent8ce402193819b366f1a8a9bdf2185a67e5959b2d (diff)
downloadidutils-a016e88bcdcabe947bfb9dea474df5fbe2081b65.tar.gz
idutils-a016e88bcdcabe947bfb9dea474df5fbe2081b65.tar.bz2
idutils-a016e88bcdcabe947bfb9dea474df5fbe2081b65.zip
Update .tarball-version-related rules from coreutils.
* GNUmakefile: Support VPATH "make dist". Namespace clean-up. Remove .version-creating rules. * configure.ac (AC_INIT): Use .tarball-version, not .version * bootstrap: Update from coreutils. * bootstrap.conf (obsolete_gnulib_modules): Remove free. * Makefile.am: Emit .tarball-version into tarball.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index aeeefec..c759c59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -13,10 +13,19 @@ EXTRA_DIST = \
bootstrap.conf \
build-aux/vc-list-files
-dist-hook:
+gen_start_date = 2008-01-01
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
if test -d .git; then \
- $(top_srcdir)/build-aux/gitlog-to-changelog --since=2008-01-01 \
- > $(distdir)/cl-t; \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
rm -f $(distdir)/ChangeLog; \
mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi
+
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
+# The perl substitution is to change some key uses of "rm" to "/bin/rm".
+# See the rm_subst comment for details.
+dist-hook: gen-ChangeLog
+ echo $(VERSION) > $(distdir)/.tarball-version